Hosed an XP Partition

"Please leave a message at the beep, we will get back to you when your support contract expires."

Moderators: phlip, Moderators General, Prelates

User avatar
Jorpho
Posts: 6221
Joined: Wed Dec 12, 2007 5:31 am UTC
Location: Canada

Hosed an XP Partition

Postby Jorpho » Mon May 25, 2015 2:32 am UTC

So I did something horrible to an XP installation I use in a virtual machine. I keep this partition FAT32 formatted since I don't want security to get in the way. Unfortunately, it's been getting just a bit too small, so after expanding the virtual drive in VMware, I fired up Knoppix so I could use GParted to resize the partition. After restarting, trying to boot from the resized partition yielded only a blank screen with a cursor blinking in a corner. At this point drive C was still readable if I booted using the FreeDOS startup disk on Ultimate Boot CD.

After Googling around, I came to the conclusion that the best thing to do would be to use the XP recovery console. I found a suitable ISO over here. As per instructions such as these, I first tried running "fixboot c:". Rather unwisely, I then immediately tried "fixmbr \Device\Harddisk0". I neglected to record any of the messages that resulted, alas.

Now the FreeDOS startup disk doesn't boot at all – I assume it's hanging when it tries to determine what's on the hard drive. GParted in Knoppix has now decided that the drive is FAT16, which of course makes no sense since it's a 6.75 GB partition.

Clearly I need some way of rebuilding the partition table, or at least of re-identifying the partition as FAT32. The exercise is largely academic at this point, but I'd like to know in case I have this problem again. What tool should I use?

ETA: Further Googling suggests that such spontaneous conversions to FAT16 are not uncommon. http://www.techspot.com/community/topic ... ope.41411/ enthusiastically endorses Partition Table Doctor, but that's a for-pay program (boo).

ETA2: Seems the information there is out of date, and Partition Table Doctor is now "EaseUS Partition Recovery Wizard", but it only runs from Windows and is of questionable utility. However, this handy thread pointed me to "testdisk", which is included in Knoppix and after much persuasion (it kept trying to identify the wrong folder as the root directory) finally gave me a recognizable partition that the FreeDOS startup disk could properly read (and that Knoppix could mount again).

Of course, the problem is that XP still won't boot. :(

ETA3: Running fixboot again from the recovery console makes everything happy again. :) Seems the moral here is to never, EVER use fixmbr with FAT32 partitions. Ayoye! (Back in the old DOS days it was such a handy method of cleaning out virus infections.)

I will leave this here for posterity. No one wants to be a Denver coder.

Return to “The Help Desk”

Who is online

Users browsing this forum: No registered users and 4 guests