OneDrive problem with windows 10

"Please leave a message at the beep, we will get back to you when your support contract expires."

Moderators: phlip, Moderators General, Prelates

User avatar
Cathode Ray Sunshine
Posts: 392
Joined: Sun Nov 04, 2007 8:05 am UTC
Location: Dominican Republic

OneDrive problem with windows 10

Postby Cathode Ray Sunshine » Thu Aug 11, 2016 11:36 pm UTC

Hey everyone, I've been having a problem with OneDrive since I upgraded to Windows 10 from 8.1 a couple of weeks ago. The transition went by very smoothly and I haven't encountered any problem except for this one. When I upgraded, I got a window at startup urging me to sign up for OneDrive. I have never used it, and I don't intend to, so I just closed it and went along with my business. The window kept appearing everytime, and I had no way to disable it. OneDrive didn't appear in the startup programs in Task Manager, so I thought that maybe I had to sign up for it and then disable it (illogical I know). I signed up and disabled it from starting. I don't mind it having it running in the background, as long as it doesn't bother me, the problem is that every single time I turn on the computer, perhaps not at startup but later on, OneDrive automatically opens the Onedrive folder after syncing, even though I don't use it, unchecked the folders it should sync and have no files there whatsoever. I've tried googling for solutions but the few (if any) that I've found don't apply to me, as I have the Home edition. I could unlink my account, but that gets me to square one where the window urges me to sign up for it every single time. Any help is appreciated.

(Sorry if the post is a mess; I had a more detailed one and the forum ate it up)

cphite
Posts: 1083
Joined: Wed Mar 30, 2011 5:27 pm UTC

Re: OneDrive problem with windows 10

Postby cphite » Fri Aug 12, 2016 9:03 pm UTC

Cathode Ray Sunshine wrote:Hey everyone, I've been having a problem with OneDrive since I upgraded to Windows 10 from 8.1 a couple of weeks ago. The transition went by very smoothly and I haven't encountered any problem except for this one. When I upgraded, I got a window at startup urging me to sign up for OneDrive. I have never used it, and I don't intend to, so I just closed it and went along with my business. The window kept appearing everytime, and I had no way to disable it. OneDrive didn't appear in the startup programs in Task Manager, so I thought that maybe I had to sign up for it and then disable it (illogical I know). I signed up and disabled it from starting. I don't mind it having it running in the background, as long as it doesn't bother me, the problem is that every single time I turn on the computer, perhaps not at startup but later on, OneDrive automatically opens the Onedrive folder after syncing, even though I don't use it, unchecked the folders it should sync and have no files there whatsoever. I've tried googling for solutions but the few (if any) that I've found don't apply to me, as I have the Home edition. I could unlink my account, but that gets me to square one where the window urges me to sign up for it every single time. Any help is appreciated.

(Sorry if the post is a mess; I had a more detailed one and the forum ate it up)


If you're really not going to use it and you have administrative rights on the machine, you could try this:

1. Press Win + R keyboard accelerator to open Run dialog box.
2. Type GPedit.msc and hit Enter or OK to open Local Group Policy Editor.
3. Navigate to Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> OneDrive.
4. In the right pane, double click on policy named Prevent the usage of OneDrive for file storage.
5. Select the Enabled radio button.

This should disable OneDrive completely; that is, you won't be able to use it even if you want to - unless you re-enable it. Note that if your machine is part of a network (at work or at school for example) their group policy could override.

That being said, I'll offer one caveat - the behavior you're describing with OneDrive popping up all the time doesn't sound normal. Which means that some other process on your machine (installed by the vendor perhaps) might actually be calling it. If that is the case, you might start seeing an error pop up instead of the window. Not saying this is going to happen, just that it could. If it does happen, hopefully the error will help track down what process is responsible.

User avatar
Cathode Ray Sunshine
Posts: 392
Joined: Sun Nov 04, 2007 8:05 am UTC
Location: Dominican Republic

Re: OneDrive problem with windows 10

Postby Cathode Ray Sunshine » Mon Aug 15, 2016 12:38 am UTC

That's one of the solutions I found online. Unfortunately, it's useless for me since it only works if you have Pro or Enterprise. All I get is an error saying Windows cannot find it. Oh well. It's weird, but Friday and Saturday I didn't get the notification, but today I did. Seems like short of going back to 8.1, I'll have to learn how to live with it.

Thanks for trying anyway. I appreciate it. :)

cphite
Posts: 1083
Joined: Wed Mar 30, 2011 5:27 pm UTC

Re: OneDrive problem with windows 10

Postby cphite » Mon Aug 15, 2016 2:25 pm UTC

Cathode Ray Sunshine wrote:That's one of the solutions I found online. Unfortunately, it's useless for me since it only works if you have Pro or Enterprise. All I get is an error saying Windows cannot find it. Oh well. It's weird, but Friday and Saturday I didn't get the notification, but today I did. Seems like short of going back to 8.1, I'll have to learn how to live with it.

Thanks for trying anyway. I appreciate it. :)


Oh, yeah - sorry - my bad. I've gotten used to using Pro ;)

All the group policy thing actually does behind the scenes is change a registry setting... You can do the same thing directly via the registry editor:

Press Win + R to open Run dialog box.
Type RegEdit.exe and hit Enter or OK to open Registry Editor.
Navigate to the following registry key: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows

Right click on Windows and select New -> Key. Name the new key as OneDrive. (Note: If OneDrive key already exists, skip this step.)

Right click on OneDrive registry key, and select New -> DWORD (32-bit) Value. Name the new value name as DisableFileSyncNGSC
Set the data for DisableFileSyncNGSC registry value as 1.

Close Registry Editor.
Sign out and sign in again, or restart the computer.

If the above doesn't resolve your problem, as a last resort it is possible to actually uninstall the OneDrive application completely; I personally wouldn't recommend doing that, but it's an option.

User avatar
Cathode Ray Sunshine
Posts: 392
Joined: Sun Nov 04, 2007 8:05 am UTC
Location: Dominican Republic

Re: OneDrive problem with windows 10

Postby Cathode Ray Sunshine » Fri Aug 19, 2016 12:46 am UTC

Hey cphite, thanks for your continued assistance with my problem. Though I truly appreciate your advice, the problem, it seems, wasn't with OneDrive but rather with my user. I know next to nothing about the inner workings of computers and their programs, so this is just my take on what happened. I installed W10 on my regular user, the one I always use (no one else uses my laptop). I think maybe something got messed up along the way and it caused OneDrive to malfunction.

I had created another username (because I hadn't seen your post and screwed up even more), and it that user, OneDrive behaved the way it should. No problem whatsoever. Not only that, but it showed the program just as OneDrive, while in my regular user it showed it as OneDrive for Business, no idea why. So I just migrated all my files to the other user and so far, 3 days in, the problem seems to be taken care of.

Thank you for taking the time to reply to my problem :)


Return to “The Help Desk”

Who is online

Users browsing this forum: No registered users and 6 guests