Laptop doesn't turn on (but on reset - fine!)

"Please leave a message at the beep, we will get back to you when your support contract expires."

Moderators: phlip, Moderators General, Prelates

User avatar
Zohar
COMMANDER PORN
Posts: 7508
Joined: Fri Apr 27, 2007 8:45 pm UTC
Location: Denver

Laptop doesn't turn on (but on reset - fine!)

Postby Zohar » Mon Oct 23, 2017 8:12 pm UTC

I have an ASUS ROG, it's about 2-3 years old. I have no issues with it generally.

Lately when I turn it on it shows the "Republic of Gamers" logo screen for a second (as it should) and then the screen would suddenly appear either all vertical striped or one thin line around the top third of the screen, then after a second the screen would turn off. The computer might still seem like it's working but it would never actually turn on again. What I then do is press and hold the power button for a couple of seconds until it shuts off, and when I boot it up again - everything's fine.

This doesn't happen all the time, but maybe 70% of the time. The second time in a row I turn it on always works out fine.

It used to be pretty much constantly connected to the TV with an HDMI cable and I never turned it off, so I don't know when this issue might have started, and I've had trouble finding other people with similar issues.

Ideas?
Mighty Jalapeno: "See, Zohar agrees, and he's nice to people."
SecondTalon: "Still better looking than Jesus."

Not how I say my name

Return to “The Help Desk”

Who is online

Users browsing this forum: No registered users and 7 guests