"User has not been granted the requested logon type"

"Please leave a message at the beep, we will get back to you when your support contract expires."

Moderators: phlip, Moderators General, Prelates

User avatar
'; DROP DATABASE;--
Posts: 3284
Joined: Thu Nov 22, 2007 9:38 am UTC
Location: Midwest Alberta, where it's STILL snowy
Contact:

"User has not been granted the requested logon type"

Postby '; DROP DATABASE;-- » Thu Mar 27, 2008 7:29 pm UTC

I have two machines running XP Pro SP2 and I can't get file sharing to work. They can see eachother; I can control the other using VNC (by host name or IP address) and ping, but they don't want to authenticate properly. I've set this up with other machines before and it worked; I create a limited account with a password, give it access to some directories, and share them. When I try to access those shares from another machine it asks for a username and password; give it that account and it works. This time it's not asking for a password, it just says:
\\shugo is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
Logon failure: the user has not been granted the requested logon type at this computer.
It seems to me like it's trying to log in with this account rather than asking for my login info. There are a lot of results for this message on Google but they all just describe different ways of enabling the Guest account, which defeats the purpose of creating that limited account with a password in the first place. V_v

The account already has all the permissions it should need: Access from the network, log on through terminal services, and log on locally, but it seems like it's not even getting to the point where that account would do anything. It's just trying to log in with some other account.

The same account with the same password exists on this machine.

There, now that I've asked for help, it's only a matter of time before I fix it. <_<
poxic wrote:You suck. And simultaneously rock. I think you've invented a new state of being.

Ragavin
Posts: 39
Joined: Mon Mar 24, 2008 9:45 pm UTC
Location: Pleasanton, Ca

Re: "User has not been granted the requested logon type"

Postby Ragavin » Thu Mar 27, 2008 7:42 pm UTC

I hate it when stuff like this happens in XP. It's such a pain to dick around with. Make sure that you have a password set on all relevant accounts or it will cause you problems. Sounds like you already do though. Make sure that shitty simple file sharing is turned off as well.

User avatar
'; DROP DATABASE;--
Posts: 3284
Joined: Thu Nov 22, 2007 9:38 am UTC
Location: Midwest Alberta, where it's STILL snowy
Contact:

Re: "User has not been granted the requested logon type"

Postby '; DROP DATABASE;-- » Sat Mar 29, 2008 7:12 pm UTC

OK, the accounts I log in locally with don't have passwords, but the network accounts do. By allowing blank passwords I can see the shares, but it's still not asking me to log in; it's just using the account I'm logged in with locally.

In case that doesn't make sense: Both machines have a "User" account, with no password, and a "Network" account with a password. The User account is what I log into when using the machine locally. The Network account is the one that has access to all the shares. When I try to access a share from another machine, it just logs in as User automatically, instead of showing a login prompt so I can log in as Network and access stuff.
poxic wrote:You suck. And simultaneously rock. I think you've invented a new state of being.

User avatar
someguy
Posts: 486
Joined: Sun Sep 16, 2007 11:43 pm UTC

Re: "User has not been granted the requested logon type"

Postby someguy » Sat Mar 29, 2008 9:16 pm UTC

I think it's more or less the same problem I had over here a while back--try mapping the network shares from a command prompt instead:

net use X: \\machine\share /user:<domain-or-machine-name>\username

It should prompt for a password and, er, work.

Note that you don't actually have to map all of your shared drives/resources; it's just a means of logging on to the remote PC with a different user account (hope that just made some sense.)
aleflamedyud wrote:Plenty of people have confidence without any base of actual virtue or accomplishment beneath it. We call these people "douchebags".


User avatar
'; DROP DATABASE;--
Posts: 3284
Joined: Thu Nov 22, 2007 9:38 am UTC
Location: Midwest Alberta, where it's STILL snowy
Contact:

Re: "User has not been granted the requested logon type"

Postby '; DROP DATABASE;-- » Sun Mar 30, 2008 4:38 am UTC

Well that was never necessary before, but I'll try:

Code: Select all

C:\>net use Z: \\shugo\c
The command completed successfully.
That works, but I get "Access is denied" trying to open it. Same if I map it from Explorer. So I disconnect it and try other things:

Code: Select all

C:\>net use Z: \\shugo\c /user:networkuser
System error 1219 has occurred.

Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again..


C:\>net use Z: \\shugo\c /user:shugo\networkuser
System error 1219 has occurred.

Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again..


C:\>net use Z: \\shugo\c /user:shugo\\networkuser
The user context supplied is invalid.

More help is available by typing NET HELPMSG 3775.
:(
poxic wrote:You suck. And simultaneously rock. I think you've invented a new state of being.

User avatar
someguy
Posts: 486
Joined: Sun Sep 16, 2007 11:43 pm UTC

Re: "User has not been granted the requested logon type"

Postby someguy » Sun Mar 30, 2008 1:17 pm UTC

'; DROP DATABASE;-- wrote:C:\>net use Z: \\shugo\c /user:shugo\networkuser
System error 1219 has occurred.

Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again..

Restart the computer (the one you're entering these commands into) and try again. It's probably cached the 'wrong' logon credentials, I don't know why it does that but it does.

You should in fact see an entry for \\shugo\c if you do a net use with no parameters.

Alternately, you *might* be able to get away without restarting by going to the other PC, opening the Computer Management console, Shared Folders > Sessions, and closing any open sessions (you should see one for the shugo\networkuser user, unless I'm totally mistaken.)

Then try again.

Good luck.
aleflamedyud wrote:Plenty of people have confidence without any base of actual virtue or accomplishment beneath it. We call these people "douchebags".


User avatar
'; DROP DATABASE;--
Posts: 3284
Joined: Thu Nov 22, 2007 9:38 am UTC
Location: Midwest Alberta, where it's STILL snowy
Contact:

Re: "User has not been granted the requested logon type"

Postby '; DROP DATABASE;-- » Mon Mar 31, 2008 2:06 am UTC

Alright, it worked after rebooting. But I never had to use the command line before. What could be different this time?
poxic wrote:You suck. And simultaneously rock. I think you've invented a new state of being.

User avatar
someguy
Posts: 486
Joined: Sun Sep 16, 2007 11:43 pm UTC

Re: "User has not been granted the requested logon type"

Postby someguy » Mon Mar 31, 2008 2:45 am UTC

To be honest, I have NO idea. I'm still trying to figure out why it does it myself. At least there's a way around it!

Actually, come think of it, your two PCs are in a workgroup, right (as opposed to a domain)? If you haven't, try creating an account with the same name and password on the other computer; then, er, restart both PCs just to be sure and try accessing the share without the command prompt trick.

I can't recall whether I've ever tried it, as I've always had a domain set up at home, but I *think* I remember having read once that for shared resources to work properly in a workgroup environment, the same user accounts have to exist on ('in'?) all of the machines.

Which sounds capricious enough to be true, considering it's Microsoft and all :roll:.
aleflamedyud wrote:Plenty of people have confidence without any base of actual virtue or accomplishment beneath it. We call these people "douchebags".


User avatar
'; DROP DATABASE;--
Posts: 3284
Joined: Thu Nov 22, 2007 9:38 am UTC
Location: Midwest Alberta, where it's STILL snowy
Contact:

Re: "User has not been granted the requested logon type"

Postby '; DROP DATABASE;-- » Mon Mar 31, 2008 3:35 am UTC

Yep, they're in the same workgroup and the same accounts with the same passwords exist on both.
poxic wrote:You suck. And simultaneously rock. I think you've invented a new state of being.

User avatar
'; DROP DATABASE;--
Posts: 3284
Joined: Thu Nov 22, 2007 9:38 am UTC
Location: Midwest Alberta, where it's STILL snowy
Contact:

Re: "User has not been granted the requested logon type"

Postby '; DROP DATABASE;-- » Tue Apr 01, 2008 3:28 am UTC

Actually that didn't work as well as I thought. Suddenly I have read-only access. :?
poxic wrote:You suck. And simultaneously rock. I think you've invented a new state of being.

coppro
Posts: 117
Joined: Mon Feb 04, 2008 6:04 am UTC

Re: "User has not been granted the requested logon type"

Postby coppro » Wed Apr 02, 2008 1:39 am UTC

Sounds like you've been hit by a virus or something - maybe you should try accessing the administrator account from safe mode and see what happens (if you have the access)

User avatar
someguy
Posts: 486
Joined: Sun Sep 16, 2007 11:43 pm UTC

Re: "User has not been granted the requested logon type"

Postby someguy » Wed Apr 02, 2008 2:33 am UTC

'; DROP DATABASE;-- wrote:Actually that didn't work as well as I thought. Suddenly I have read-only access. :?

Stupid question, but you DID share the folders/files as R/W, yes?
aleflamedyud wrote:Plenty of people have confidence without any base of actual virtue or accomplishment beneath it. We call these people "douchebags".


vjtod
Posts: 3
Joined: Tue Oct 09, 2007 4:43 am UTC

Re: "User has not been granted the requested logon type"

Postby vjtod » Wed Apr 02, 2008 4:23 am UTC

Sometimes Windows XP is set not to allow remote login with local accounts and will always try to default connections to guest.
If you're using Pro you can check:
Start -> Run -> gpedit.msc -> Local Computer Policy -> Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options -> Network access: Sharing and security model for local accounts
Make sure that's set to "Classic - local users blah blah blah" and not "Guest only - Blah blah blah"

Then as long as account names (actual username, not Full Name) match and passwords are the same it will log you in automatically via explorer.

someguy wrote:
'; DROP DATABASE;-- wrote:Actually that didn't work as well as I thought. Suddenly I have read-only access. :?

Stupid question, but you DID share the folders/files as R/W, yes?

Important point there, default is read only I believe.

User avatar
'; DROP DATABASE;--
Posts: 3284
Joined: Thu Nov 22, 2007 9:38 am UTC
Location: Midwest Alberta, where it's STILL snowy
Contact:

Re: "User has not been granted the requested logon type"

Postby '; DROP DATABASE;-- » Wed Apr 02, 2008 4:53 am UTC

It was set to writeable, and I could write again after a reboot. Also that setting is set to Classic on both machines.
poxic wrote:You suck. And simultaneously rock. I think you've invented a new state of being.


Return to “The Help Desk”

Who is online

Users browsing this forum: No registered users and 5 guests