HP Envy Touchsmart 15 with Debian (State of NVidia Optimus)

The magic smoke.

Moderators: phlip, Moderators General, Prelates

beojan
Posts: 166
Joined: Mon May 23, 2011 12:11 pm UTC
Location: Oxford / London, United Kingdom, Europe

HP Envy Touchsmart 15 with Debian (State of NVidia Optimus)

Postby beojan » Tue Aug 06, 2013 10:54 am UTC

In particular, I'm thinking of getting this machine:
HP Envy Touchsmart 15
with a i7-4700MQ (Haswell) processor, and a GT 740M discrete GPU.

Does anyone know how well NVidia Optimus is supported under Linux (specifically Debian Sid), and also whether it is possible to either disable secure boot, or install the correct keys to boot Debian on this machine?

Also, does anyone know where I can find out whether this laptop has a hardware multiplexer (which would allow Optimus to be disabled in the BIOS, using only the discrete GPU)?
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Edit to change title
Last edited by beojan on Wed Sep 04, 2013 8:45 pm UTC, edited 1 time in total.

User avatar
Sebastiaan
Posts: 23
Joined: Mon Nov 12, 2012 10:02 am UTC
Location: Leiden, the Netherlands

Re: State of NVidia Optimus on Linux

Postby Sebastiaan » Sat Aug 17, 2013 4:42 pm UTC

I don't think, but I haven't checked lately, that there is no "official" Optimus support for any Linux distributions. The last I've read is that NVidia has not provided a driver for Linux, let alone an open-source one. There is however a workaround that works on Debian: Bumblebee. You can find plenty of guides on how to install it on your distribution using google. It has been working for me for a while now (Intel Core i7-2630QM; GT 540M) with both Ubuntu and now Fedora.

For the secure boot question you might want to check out Linux or distribution-specific community boards as it's probably been discussed there.

beojan
Posts: 166
Joined: Mon May 23, 2011 12:11 pm UTC
Location: Oxford / London, United Kingdom, Europe

Re: State of NVidia Optimus on Linux

Postby beojan » Wed Sep 04, 2013 8:43 pm UTC

I believe NVidia have in fact now released an Optimus driver (or at least, a partial solution) here. I'm willing to forgo any 'must be free software' requirements in order to have working discrete graphics, so I'll probably use the non-free driver. However, it requires having the discrete card running all the time, rendering the whole desktop.

I've ordered the machine, so when it arrives, I'll probably post here with details of what works / how I got it working

Edit:
I've now received the machine.
Booting with UEFI works after disabling secure boot. When installing Debian, I had to elect to use the existing EFI system partition as the "EFI Boot Partition" in the installer.
Also, by default, it will boot directly into Win 8 unless the F9 hotkey is used. I fixed this by renaming /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi to bootmgfw-2.efi, copying /boot/efi/EFI/debian/grubx64.efi to /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi, then editing /boot/grub/grub.cfg to fix the path to the Windows boot loader so that I could boot Windows from GRUB. Other methods of changing the boot order had no effect.

The NVidia card works with bumblebee after installing from the repos. I used the newest NVidia driver from the experimental repo. However, attempting to start firefox with primusrun causes it to crash.

Touchpad works with the Synaptics driver, but there is no pinch to zoom or rotate. Two finger scroll works, and setting the VertScrollDelta and HorizScrollDelta to negative values allows "Natural Scrolling"
The Wifi card works once all firmware packages are installed.

The touchscreen is detected by X, and xinput lists it, but touches do not move the pointer.
EDIT: With the latest Xorg packages, touchscreen input now works. Multitouch support also works, although there are no applications that currently make use of this.
The subwoofer and rear speakers are not detected in Debian. Research suggests this is fixed by correcting the pin assignments with hdajackretask.
EDIT: I have now got the rear speakers and subwoofer working.
For those with the same notebook, the pin assignments to use in hdajackretask are:
  • 0x0D -> Internal Speaker
  • 0x0F -> Internal Speaker (Back)
  • 0x10 -> Internal Speaker (LFE) #This is the subwoofer
However, ALSA appears to treat all three as front speakers, so surround sound audio does not work (All speakers receive first two channels)

The fingerprint reader is detected in lsusb, but is not supported by libfprint.
EDIT: Payden Sutherland is developing a libfprint driver for this fingerprint reader here: http://paydensutherland.com/2014/01/libfprint-138a-0050-driver/#comments. It works reasonably well.


Last bumped by beojan on Wed Sep 04, 2013 8:43 pm UTC.


Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 6 guests